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Installing the WAsP helper scripts in QGIS
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You will need to install QGIS for this exercise. Following the instructions 
on https://download.qgis.org/
The following has been tested using versions 3.10.5 up to the newest 
version 3.32

In addition, you must download the plugin “wasp_scripts.zip” available 
here:
https://data.dtu.dk/articles/software/Using_QGIS_to_create_WAsP_ma
ps/20495178

Go to Plugins > Manage and Install plugins > Install from ZIP, provide to 
zip file above and click Install Plugin

https://download.qgis.org/
https://data.dtu.dk/articles/software/Using_QGIS_to_create_WAsP_maps/20495178
https://data.dtu.dk/articles/software/Using_QGIS_to_create_WAsP_maps/20495178
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Installing the WAsP helper scripts in QGIS
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Make sure the WAsP scripts are visible by showing 

the Processing Toolbox
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Adding Google Earth as a background

1. Use this URL as indicated below
– https://www.google.com/maps/vt?lyrs=s@189&gl=cn

&x={x}&y={y}&z={z}

If the URL above does not display, try to restart QGIS or you can try 

this alternative:

– http://ecn.t3.tiles.virtualearth.net/tiles/a{q}.jpeg?g=1
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Right click and select ‘New connection’

Double click on item ‘Google 

Earth’ that is now added. The 

satellite background should 

appear

https://mt1.google.com/vt/lyrs=s&x=%7bx%7d&y=%7by%7d&z=%7bz%7d
https://mt1.google.com/vt/lyrs=s&x=%7bx%7d&y=%7by%7d&z=%7bz%7d
http://ecn.t3.tiles.virtualearth.net/tiles/a%7bq%7d.jpeg?g=1
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Working with layers

• In the layers panel you can see different layers that 

you will load into the canvas (area with the satellite 

map).

• Most processes in QGIS by default create 

temporary layers, you will have to save them to disk 

if you want to keep them! We recommend saving 

vector files as ‘.gpkg’. You can learn more in this 

video.
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https://panopto.dtu.dk/Panopto/Pages/Viewer.aspx?id=0aeaf657-0793-4e2c-88e6-b0d800dbca22
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Projections & coordinates
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Changing the projection

The google earth tiles have projection EPSG:3857. Once you loaded this layer, 

this projection was automatically adopted for your canvas. It is easy to change for 

other projections by clicking on this button and search by the ‘Authority ID’, which 

is a standardized code for frequently used projections.

Some commonly used codes are:

• Geographic: EPSG:4326 (for geographic lat/lon projection)

• Projected: EPSG:32HNN, where H is 6 on northern hemisphere and 7 on the 

southern hemisphere and NN is the zone number. An overview of the UTM 

zones can be found here

For WAsP we can only use projected coordinate systems with unit meters, such 

as UTM. The scripts will not work for geographic projections.

Checking coordinates of your cursor position

Make sure your 

site is in the red 

area, where the 

chosen projection 

is valid

https://mangomap.com/robertyoung/maps/69585/what-utm-zone-am-i-in-
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What you will learn

• This exercise covers five procedures:

A. Importing an elevation map from GWA warehouse

B. Creating a hand-digitized roughness map using Google Earth satellite data 

C. Importing a roughness map from the CORINE database (can be used for your projects 

if they are in Europe)

D. Importing a roughness map from the GWA database

E. Importing a roughness map from the WorldCover database

6
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➢ Task: make an elevation map for the region around the Risø campus:

– Close to the meteorological mast at 55.694219˚N, 12.088316˚E

Exercise A – Importing an elevation map from GWA

• Run the script using the lat/lon given 

above

✓ This will create a square polygon 

around the given lat/lon with the 

given extent called Bounding box
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If you run a QGIS script the 

default is that it will operate 

on the current layer and 

generate a new temporary 

layer that will show up in 

your list in the ‘Layers’ 

panel.

1) Creating a bounding box
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Exercise A – Importing an elevation map from GWA

2) Run the script ‘Get GWA elevation lines’

Select contouring 

interval for your 

map, in this case 

a line will be 

drawn every 10 m
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• In the Processing toolbox 

double click on “Save WAsP 

elevation layer”

• In the following window for the 

input layer select the Output 

layer and click Save to file

9

3) Save the created map to disk

Exercise A – Importing an elevation map from GWA
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Exercise B – Digitizing a roughness map in QGIS

In this exercise we will create a roughness map by 

digitizing google earth information.

• Add the google earth background layer from 

exercise 1A (if not present yet)

• Double click on the script ‘Create hand digitized 

landcover polygons’

• Select the appropriate ‘Output coordinate 

reference system’ that you want to make your 

map in (see exercise A).

• Press ‘run’
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1) Create a hand-digitized polygon layer

Some settings in your project are modified in this script to make sure no errors occur when 

digitizing. You will notice they look like below. You can read more about these in the QGIS 

help about snapping. You can also watch this video to learn more details. Particularly watch 

this video if you save your polygons on disk and resume work later, because project settings 

are not saved after you quite QGIS.

https://docs.qgis.org/3.28/en/docs/user_manual/working_with_vector/editing_geometry_attributes.html?highlight=snapping#snapping-and-digitizing-options
https://panopto.dtu.dk/Panopto/Pages/Viewer.aspx?id=fa7ea924-c558-4d92-bbf1-b0d800dbcb1a
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• Press Toggle editing 

• Press Add Polygon feature 

• Digitize a feature by left-clicking on the map at the desired points. Cross-points are shown by a 

green cross and should be avoided. 

• Finish digitizing by right-click and fill in a z0 (roughness length value). The other columns you 

can leave at their defaults (optionally you can add a description ‘desc’ like ‘forest, grass’).

• Save your edits
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Exercise B – Digitizing a roughness map in QGIS

2) Digitize features in the map and assign a roughness
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Exercise B – Digitizing a roughness map in QGIS

• You can explore the features in a layer (in this case the hand-digitized) by right-click and 

‘Open Attribute Table’. You can start editing them by pressing the pencil symbol in the 

upper left corner.
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2) Modifying existing polygons in your layer
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• Double click WAsP scripts > Polygons to roughness lines. Remember to uncheck the box 

‘Clip border roughness lines’ and specify an appropriate ‘Roughness length outside 

specified areas’ press Run.

• Select the output layer that results from the above and double click WAsP scripts > Save 

WAsP roughness layer choose Save to file with the filename ‘roughness.map’ and click 

Run

• You can open the ‘WAsP map editor’ and make sure your map has no errors

13

Exercise B – Digitizing a roughness map in QGIS

3) Convert polygons to roughness lines and save to disk
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1) Double click the script “Get CORINE landcover polygons”

• Select the Bounding box layer that was already used for the elevation map

Exercise C – Importing a CORINE roughness map 
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2) Double click the script “Polygons to roughness lines”
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Make sure to 

check the option 

‘Clip border 

roughness lines’ 

is checked, so 

that the map has 

‘open ends’

Exercise C – Importing a CORINE roughness map 
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3) Save the created layer to disk

16

Exercise C – Importing a CORINE roughness map 

In the Processing toolbox select 
“Save WAsP roughness layer”

For the input layer select the 
roughness lines and click Save 
to file to a place on your disk
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Exercise D – Importing a GWA roughness map 
1) Double click on the script “Get GWA landcover polygons”

• Select the Bounding box layer that was already used for the elevation map
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Exercise D – Importing a GWA roughness map 

2) Run the script “Polygons to roughness lines”

Make sure to 

check the option 

‘Clip border 

roughness lines’ 

is checked
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Exercise D – Importing a GWA roughness map 
3) Save the created layer to disk

In the Processing toolbox 
double click on “Save WAsP 
roughness layer”

In the following window for the 
input layer select the 
roughness lines layer and click 
Save to file
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Exercise E – Importing a WorldCover roughness map 

1) Run the script “Get WorldCover landcover 

polygons”

• Select the Bounding box layer that was 

already used for the elevation map

• The highest possible resolution is 50 m, the 

default recommended resampling to 100 m 

makes the maps easier to process
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Exercise E – Importing a WorldCover roughness map 

2) Run the script “Polygons to roughness lines”

Make sure to 

check the option 

‘Clip border 

roughness lines’ 

is checked
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Exercise E – Importing a WorldCover roughness map 
3) Save the created layer to disk

In the Processing toolbox 
double click on “Save WAsP 
roughness layer”

In the following window for the 
input layer select the 
roughness lines layer and click 
Save to file
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Final WAsP workspace

• You can open the .map files that 

we have created directly in 

WAsP by right clicking on the 

project and click ‘Insert from file > 

Vector map’

• If you have already imported a 

roughness layer and want to add

a elevation layer (or vice versa), 

right click on the map and 

select ‘Insert from file > Vector

map data layer’

23
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Frequently asked questions:

• I have another questions that is not below?

– Check the WAsP forum https://www.wasptechnical.dk/forum/index.php or send an email to WAsP support (waspsupport@dtu.dk)

• My google maps image does not show up:

– Restart QGIS and try again

– Use the alternative source by adding Bing maps in
• http://ecn.t3.tiles.virtualearth.net/tiles/a{q}.jpeg?g=1

• Can I edit a polygon and change a property?

– Yes you can, see for example this video

• I want to add a new polygon in my layer because it does not correspond to reality.

– Watch this video

• How can I make sure there is no gaps between polygons when I digitize?

– See exercise B, step 2. When you avoid overlap you can draw over the area that is covered by another polygon. The new polygon

will then ‘snap’ to the edge of the old one. Make sure the option ‘Topological editing’ is selected, otherwise inconsistencies between 

the different polygons can show up. To check the validity of your polygon layer, you can install the plugin ‘Check geometries’.

• How do I change the language in QGIS?

– Go to Settings > Options > General > “Override system local”

• How do I reproject my vector layer?

– Go to Vector > Data management tools > Reproject Layer

• How do I reproject my raster layer?

– Go to Raster > Projectons > Warp (reproject)

• I get an error:

Warning 1: Model file not specified. Process returned error code 1

Try the fix in this suggestion: https://github.com/qgis/QGIS/issues/54375

24

https://www.wasptechnical.dk/forum/index.php
mailto:waspsupport@dtu.dk
http://ecn.t3.tiles.virtualearth.net/tiles/a%7bq%7d.jpeg?g=1
https://panopto.dtu.dk/Panopto/Pages/Viewer.aspx?id=0394a399-d5c2-4a71-9954-b0d800dbcb7f
https://panopto.dtu.dk/Panopto/Pages/Viewer.aspx?id=34150fab-cc7f-42af-af41-b0d800dbca95
https://github.com/qgis/QGIS/issues/54375
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